Bug#627410: initscript assumes /lib/udev/mtp-probe is there when its not

May 20th, 2011 - 08:10 am ET by Kevin Mitchell | Report spam
Package: udev
Version: 169-1
Severity: normal

During bootup, I was seeing
Fri May 20 04:41:03 2011: udevd[1061]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4 2 3': No such file or directory

This was remedied by installing the libmtp-runtime package which provideds /lib/udev/mtp-probe'. I wasn't able to determine where exactly the attempt to execute mtp-probe was happening, but it should probably check that the executable is there before executing it if it is not part of the package or a dependency.



Debian Release: wheezy/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.39.02 (SMP w/4 CPU cores)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages udev depends on:
ii debconf [debconf-2.0] 1.5.39 Debian configuration management sy
ii libc6 2.13-4 Embedded GNU C Library: Shared lib
ii libselinux1 2.0.98-1+b1 SELinux runtime shared libraries
ii libudev0 169-1 libudev shared library
ii lsb-base 3.2-27 Linux Standard Base 3.2 init scrip
ii util-linux 2.17.2-9.1 Miscellaneous system utilities

Versions of packages udev recommends:
ii pciutils 1:3.1.7-9 Linux PCI Utilities
ii usbutils 1:001-1 Linux USB utilities

udev suggests no packages.

/etc/modprobe.d/blacklist.conf changed:
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist am53c974
blacklist iTCO_wdt
blacklist pcspkr
blacklist snd_pcsp


udev/new_kernel_needed: false
udev/title/upgrade:
udev/reboot_needed:
udev/sysfs_deprecated_incompatibility:



To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
email Follow the discussionReplies 1 replyReplies Make a reply

Replies

#1 md
May 20th, 2011 - 11:30 am ET | Report spam

reassign 627410 libmtp8
thanks

On May 20, Kevin Mitchell wrote:

This was remedied by installing the libmtp-runtime package which provideds /lib/udev/mtp-probe'. I wasn't able to determine where exactly the attempt to execute mtp-probe was happening, but it should probably check that the executable is there before executing it if it is not part of the package or a dependency.



No, libmtp8 should deal with this.

ciao,
Marco






To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact

Similar topics